Bitcoin (BTC) and Ethereum (ETH) returning incorrect fiat value

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Oct 29, 2021 - 17:38 CEST

Investigating

We are investigating an issue where Ledger Live will display an incorrect fiat value (USD, EUR, etc...) equivalent for Bitcoin (BTC) and Ethereum (ETH). Rest assured that this is purely a countervalue issue, it has no impact whatsoever on your assets.
Posted Oct 29, 2021 - 14:38 CEST