Blockchain Ethereum (ETH) explorer is down.

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Aug 31, 2023 - 12:31 CEST

Investigating

We have detected an issue with Ledger services for blockchain Ethereum (ETH). This is being investigated by the team.
Posted Aug 31, 2023 - 12:17 CEST
This incident affected: Ledger Explorers (Ethereum (ETH)).