Polkadot (DOT) Mainnet Service Disruption

Incident Report for Ledger

Update

We are continuing to investigate this issue.
Posted Jun 12, 2026 - 21:45 CEST

Investigating

We are experiencing technical issues with the Polkadot (DOT) Mainnet within Ledger Wallet. This may impact your ability to send transactions and/or swap using Polkadot (only when the DOT is a source coin). Our team is actively working to resolve the issue. For urgent transactions, please refer to this article for alternative methods.
Posted Jun 12, 2026 - 19:55 CEST
This incident affects: Ledger Explorers (Polkadot (DOT)).