Generic issue with Explorers service
Incident Report for
Ledger
Resolved
This incident has been resolved.
Posted
Nov
02
,
2020
-
23:04
CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Nov
02
,
2020
-
22:58
CET
Identified
The issue has been identified and a fix is being implemented.
Posted
Nov
02
,
2020
-
22:54
CET
Update
We are continuing to investigate this issue.
Posted
Nov
02
,
2020
-
21:58
CET
Investigating
We are currently investigating this issue.
Posted
Nov
02
,
2020
-
21:56
CET
This incident affected: Ledger Explorers (Bitcoin (BTC), Bitcoin Gold (BTG), Dash (DASH), Decred (DCR), Digibyte (DGB), Dogecoin (DOGE), Horizen (ZEN), Komodo (KMD), Litecoin (LTC), Peercoin (PPC), Pivx (PIVX), Qtum (QTUM), Zcash (ZEC)).
×
Subscribe to Incident
Subscribe to updates for
Generic issue with Explorers service
via . You'll receive .