Polkadot (DOT) Mainnet api is down.

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Sep 18, 2024 - 18:50 CEST

Investigating

We have detected an issue with Ledger services for blockchain Polkadot (DOT) Mainnet. This is being investigated by the team.
Posted Sep 17, 2024 - 19:31 CEST
This incident affected: Ledger Explorers (Polkadot (DOT)).