Ledger Live - Temporary outage
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 11:13 CEST
Investigating
Our hosting solution is experiencing issues which is affecting Ledger Live. This mean that you may not be able to perform transactions, see your updated balance, get access to the Manager tab or get accurate countervalue data.
Rest assured this has no impact whatsoever on your assets, we are investigating the issue.
Posted Oct 13, 2021 - 10:07 CEST