Polygon (MATIC) Mainnet api does not have the latest blockchain data.
Incident Report for Ledger
Resolved
FSN disabled from loadbalacer
Posted Feb 06, 2024 - 21:29 CET
Investigating
We have detected an issue with fetching the latest blockchain data from Polygon (MATIC) Mainnet. This is being investigated by the team.
Posted Feb 06, 2024 - 17:54 CET
This incident affected: Ledger Explorers (Polygon (MATIC)).