Ledger Wallet App (Desktop & Mobile) Experiencing Latency and Launch Issues

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 15:30 CEST

Investigating

The Ledger Wallet application (Desktop and Mobile) is experiencing technical issues. Our technical teams are actively investigating. Users may experience higher latency and intermittent issues when opening the app.
Posted Aug 26, 2026 - 14:53 CEST
This incident affected: Crypto Assets Service.