Polkadot (DOT) Mainnet Service Disruption
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 17:49 CET
Investigating
We have detected an issue with Ledger services for blockchain Polkadot (DOT) Mainnet. This is being investigated by the team. This may impact your ability to send transactions, and swap DOT in Ledger Live. For urgent transactions, please refer to https://support.ledger.com/article/Unable-to-Send-or-Swap-Polkadot-DOT-in-Ledger-Live for alternative methods.
Posted Nov 18, 2024 - 19:14 CET
This incident affected: Ledger Explorers (Polkadot (DOT)).