"Explorer VIA" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 29, 2020 - 08:47 CEST
Investigating
Error code HTTP 503 - Service Unavailable
Posted Aug 29, 2020 - 08:38 CEST
This incident affected: Ledger Explorers (Viacoin (VIA)).