XTZ explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 24, 2022 - 02:25 CEST
Investigating
We have detected a problem with getting latest blockchain data from XTZ explorer. We are checking this incident.
Posted Sep 24, 2022 - 02:23 CEST
This incident affected: Ledger Explorers (Tezos (XTZ)).