BTC Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jan 02, 2021 - 19:15 CET
Investigating
BTC Explorer API Latency is critical.
Posted Jan 02, 2021 - 19:15 CET
This incident affected: Ledger Explorers (Bitcoin (BTC)).