XTZ explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jul 18, 2022 - 16:32 CEST
Investigating
XTZ explorer API test has failures detected. We are checking this incident.
Posted Jul 18, 2022 - 16:14 CEST
This incident affected: Ledger Explorers (Tezos (XTZ)).