ZEC Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 19, 2020 - 00:47 CET
Investigating
ZEC Explorer API Latency is critical.
Posted Nov 19, 2020 - 00:45 CET
This incident affected: Ledger Explorers (Zcash (ZEC)).