"Explorer ZCASH" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Apr 09, 2021 - 19:18 CEST
Investigating
Error code HTTP 503 - Service Unavailable
Posted Apr 09, 2021 - 19:10 CEST
This incident affected: Ledger Explorers (Zcash (ZEC)).