"Explorer ATOM" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 17, 2021 - 18:34 CEST
Investigating
Error code HTTP 503 - Service Unavailable
Posted Aug 17, 2021 - 18:31 CEST
This incident affected: Ledger Explorers (Cosmos (ATOM)).