"Explorer BCH" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jan 21, 2021 - 08:29 CET
Investigating
Error code HTTP 503 - Service Unavailable
Posted Jan 21, 2021 - 07:19 CET
This incident affected: Ledger Explorers (Bitcoin Cash (BCH)).