XRP - temporary issue
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Oct 25, 2021 - 20:27 CEST
Investigating
We are currently investigating an issue that prevents our users from properly interacting with their XRP (sending, receiving, creating an account). Rest assured that this issue has no impact whatsoever on your assets.
Posted Oct 25, 2021 - 13:03 CEST