DOGE explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 09:48 CEST
Investigating
DOGE explorer API test has failures detected. We are checking this incident.
Posted Jul 14, 2020 - 09:12 CEST
This incident affected: Ledger Explorers (Dogecoin (DOGE)).