ETH Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 15, 2022 - 16:54 CEST
Investigating
We have detected a problem with getting latest blockchain data from ETH Explorer. We are checking this incident.
Posted Sep 15, 2022 - 16:22 CEST
This incident affected: Ledger Explorers (Ethereum (ETH)).