ATOM explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 19, 2021 - 16:10 CEST
Investigating
ATOM explorer API test has failures detected. We are checking this incident.
Posted May 19, 2021 - 16:06 CEST
This incident affected: Ledger Explorers (Cosmos (ATOM)).