CRO Node API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 09:03 CEST
Investigating
CRO Node API Latency is critical.
Posted Jun 21, 2022 - 08:56 CEST
This incident affected: Ledger Explorers (Cryptoorg (CRO)).