XTZ explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 13, 2020 - 15:17 CET
Investigating
XTZ explorer API test has failures detected. We are checking this incident.
Posted Nov 12, 2020 - 15:05 CET
This incident affected: Ledger Explorers (Tezos (XTZ)).