XST explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 10:47 CEST
Investigating
XST explorer API test has failures detected. We are checking this incident.
Posted Jul 21, 2020 - 10:44 CEST
This incident affected: Ledger Explorers (Stealthcoin (XST)).