Explorer XTZ is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 24, 2022 - 05:05 CEST
Investigating
We are currently investigating this issue.
Posted Sep 24, 2022 - 03:39 CEST
This incident affected: Ledger Explorers (Tezos (XTZ)).