ETH explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 24, 2021 - 15:45 CEST
Investigating
ETH explorer API test has failures detected. We are checking this incident.
Posted Aug 24, 2021 - 15:43 CEST
This incident affected: Ledger Explorers (Ethereum (ETH)).