XTZ node API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jul 02, 2021 - 20:34 CEST
Investigating
XTZ node API test has failures detected. We are checking this incident.
Posted Jul 02, 2021 - 20:04 CEST
This incident affected: Ledger Explorers (Tezos (XTZ)).