Explorer XTZ is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 11, 2021 - 11:16 CET
Investigating
Error code HTTP 503 - Service Unavailable
Posted Mar 11, 2021 - 10:56 CET
This incident affected: Ledger Explorers (Tezos (XTZ)).