XTZ explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 11, 2021 - 09:21 CEST
Investigating
XTZ explorer API test has failures detected. We are checking this incident.
Posted May 11, 2021 - 09:14 CEST
This incident affected: Ledger Explorers (Tezos (XTZ)).