XST Explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Feb 08, 2021 - 09:17 CET
Investigating
XST Explorer API test has failures detected. We are checking this incident.
Posted Feb 08, 2021 - 09:13 CET
This incident affected: Ledger Explorers (Stealthcoin (XST)).