DOT explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 24, 2021 - 16:01 CET
Investigating
DOT explorer API test has failures detected. We are checking this incident.
Posted Nov 24, 2021 - 14:49 CET
This incident affected: Ledger Explorers (Polkadot (DOT)).