ETH Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 11, 2022 - 21:13 CEST
Investigating
We have detected a problem with getting latest blockchain data from ETH Explorer. We are checking this incident.
Posted Aug 11, 2022 - 20:51 CEST
This incident affected: Ledger Explorers (Ethereum (ETH)).