"Explorer ATOM" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Feb 18, 2021 - 14:47 CET
Investigating
Error code HTTP 502 - Bad Gateway
Posted Feb 18, 2021 - 14:45 CET
This incident affected: Ledger Explorers (Cosmos (ATOM)).