DOT explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jan 09, 2023 - 21:08 CET
Investigating
We have detected a problem with getting latest blockchain data from DOT explorer. We are checking this incident.
Posted Jan 09, 2023 - 21:02 CET
This incident affected: Ledger Explorers (Polkadot (DOT)).