All Systems Operational
Ledger Live Manager Operational
90 days ago
99.99 % uptime
Today
Ledger Application Store Operational
90 days ago
99.98 % uptime
Today
Ledger Live Security Services Operational
90 days ago
100.0 % uptime
Today
Ledger Explorers Operational
90 days ago
99.91 % uptime
Today
Algorand (ALGO) Operational
90 days ago
99.96 % uptime
Today
Avalanche C (AVAX) Operational
90 days ago
99.98 % uptime
Today
Binance (BNB) Operational
90 days ago
99.97 % uptime
Today
Bitcoin (BTC) Operational
90 days ago
99.98 % uptime
Today
Bitcoin Cash (BCH) Operational
90 days ago
99.98 % uptime
Today
Bitcoin Gold (BTG) Operational
90 days ago
100.0 % uptime
Today
Cardano (ADA) Operational
90 days ago
99.96 % uptime
Today
Casper (CSPR) Operational
90 days ago
100.0 % uptime
Today
Celo (CELO) Operational
90 days ago
99.99 % uptime
Today
Cosmos (ATOM) Operational
90 days ago
99.56 % uptime
Today
Cronos (CRO) Operational
90 days ago
99.93 % uptime
Today
Dash (DASH) Operational
90 days ago
99.89 % uptime
Today
Decred (DCR) Operational
90 days ago
100.0 % uptime
Today
Digibyte (DGB) Operational
90 days ago
99.98 % uptime
Today
Dogecoin (DOGE) Operational
90 days ago
100.0 % uptime
Today
Elrond (EGLD) Operational
90 days ago
100.0 % uptime
Today
Ethereum (ETH) Operational
90 days ago
99.92 % uptime
Today
Ethereum Classic (ETC) Operational
90 days ago
99.99 % uptime
Today
Filecoin (FIL) Operational
90 days ago
99.99 % uptime
Today
Hedera (HBAR) Operational
90 days ago
100.0 % uptime
Today
Horizen (ZEN) Operational
90 days ago
99.93 % uptime
Today
Internet Computer (ICP) Operational
90 days ago
100.0 % uptime
Today
Komodo (KMD) Operational
90 days ago
99.99 % uptime
Today
Litecoin (LTC) Operational
90 days ago
99.97 % uptime
Today
NEAR Protocol (NEAR) Operational
90 days ago
99.98 % uptime
Today
Peercoin (PPC) Operational
90 days ago
100.0 % uptime
Today
Pivx (PIVX) Operational
90 days ago
99.98 % uptime
Today
Polkadot (DOT) Operational
90 days ago
99.9 % uptime
Today
Polygon (MATIC) Operational
90 days ago
99.87 % uptime
Today
Qtum (QTUM) Operational
90 days ago
99.92 % uptime
Today
Ripple (XRP) Operational
90 days ago
100.0 % uptime
Today
Solana (SOL) Operational
90 days ago
99.91 % uptime
Today
Stacks (STX) Operational
90 days ago
99.1 % uptime
Today
Stellar (XLM) Operational
90 days ago
99.99 % uptime
Today
Tezos (XTZ) Operational
90 days ago
98.91 % uptime
Today
Tron (TRX) Operational
90 days ago
99.98 % uptime
Today
Vertcoin (VTC) Operational
90 days ago
99.99 % uptime
Today
Viacoin (VIA) Operational
90 days ago
99.99 % uptime
Today
Zcash (ZEC) Operational
90 days ago
99.99 % uptime
Today
Buy Operational
90 days ago
100.0 % uptime
Today
Earn Dashboard Operational
90 days ago
99.92 % uptime
Today
Countervalue API Operational
90 days ago
100.0 % uptime
Today
Swap API Operational
90 days ago
100.0 % uptime
Today
Tezos Bakers API Operational
90 days ago
100.0 % uptime
Today
NFT Metadata Service Operational
90 days ago
99.96 % uptime
Today
Ledger Connect Operational
90 days ago
100.0 % uptime
Today
Ledger Quest Operational
90 days ago
100.0 % uptime
Today
Ledger Recover Operational
90 days ago
99.91 % uptime
Today
Refer-a-friend page Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Ledger Application Store latency
Fetching
Ledger Live Security Services API latency
Fetching
Ledger Countervalue API latency
Fetching
Bitcoin (BTC) explorer latency
Fetching
Ethereum (ETH) explorer latency
Fetching
Litecoin (LTC) explorer latency
Fetching
Past Incidents
Mar 28, 2024

No incidents reported today.

Mar 27, 2024

No incidents reported.

Mar 26, 2024
Resolved - This incident has been resolved.
Mar 26, 01:30 CET
Investigating - We have detected an issue with fetching the latest blockchain data from Tezos (XTZ) Mainnet. This is being investigated by the team.
Mar 25, 23:58 CET
Mar 25, 2024
Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024
Resolved - This incident has been resolved.
Mar 22, 08:12 CET
Investigating - We have detected an issue with fetching the latest blockchain data from Near Protocol (NEAR) Mainnet. This is being investigated by the team.
Mar 22, 08:04 CET
Resolved - This incident has been resolved.
Mar 22, 03:01 CET
Investigating - We have detected an issue with fetching the latest blockchain data from Near Protocol (NEAR) Mainnet. This is being investigated by the team.
Mar 22, 02:53 CET
Mar 21, 2024

No incidents reported.

Mar 20, 2024
Resolved - This incident has been resolved.
Mar 20, 16:39 CET
Investigating - We have detected an issue with fetching the latest blockchain data from Cosmos (ATOM) Mainnet. This is being investigated by the team.
Mar 20, 14:25 CET
Resolved - This incident has been resolved.
Mar 20, 16:11 CET
Investigating - We have detected an issue with Ledger services for blockchain Cosmos (ATOM) Mainnet. This is being investigated by the team.
Mar 20, 12:14 CET
Resolved - This incident has been resolved.
Mar 20, 15:12 CET
Investigating - We have detected an issue with Ledger services for blockchain Cosmos (ATOM) Mainnet. This is being investigated by the team.
Mar 20, 12:36 CET
Resolved - This incident has been resolved.
Mar 20, 12:44 CET
Investigating - We have detected an issue with fetching the latest blockchain data from Cosmos (ATOM) Mainnet. This is being investigated by the team.
Mar 20, 12:23 CET
Resolved - This incident has been resolved.
Mar 20, 02:32 CET
Investigating - We have detected an issue with fetching the latest blockchain data from Ethereum (ETH) Mainnet. This is being investigated by the team.
Mar 19, 23:27 CET
Mar 19, 2024
Mar 18, 2024
Resolved - This incident has been resolved.
Mar 18, 16:55 CET
Investigating - We have detected an issue with fetching the latest blockchain data from Cosmos (ATOM) Mainnet. This is being investigated by the team.
Mar 18, 16:33 CET
Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024
Resolved - This incident has been resolved.
Mar 15, 20:05 CET
Investigating - We have detected an issue with fetching the latest blockchain data from Algorand (ALGO) Mainnet. This is being investigated by the team.
Mar 15, 19:47 CET
Resolved - This incident has been resolved.
Mar 15, 20:03 CET
Investigating - We have detected an issue with fetching the latest blockchain data from Tezos (XTZ) Mainnet. This is being investigated by the team.
Mar 15, 19:47 CET
Resolved - This incident has been resolved.
Mar 15, 20:00 CET
Investigating - You may not be able to send, stake/unstake or swap your SOL, our team is currently working to fix this. Read more on this issue and the workarounds here:

https://support.ledger.com/hc/en-us/articles/17531561702813-Temporary-issue-with-Staking-and-Sending-Solana-SOL-in-Ledger-Live-desktop?support=true

Mar 14, 22:09 CET
Resolved - This incident has been resolved.
Mar 15, 17:22 CET
Investigating - We have detected an issue with Ledger services for blockchain Solana (SOL) Mainnet. This is being investigated by the team.
Mar 15, 17:20 CET
Resolved - This incident has been resolved.
Mar 15, 17:06 CET
Investigating - We have detected an issue with Ledger services for blockchain Solana (SOL) Mainnet. This is being investigated by the team.
Mar 15, 17:03 CET
Resolved - This incident has been resolved.
Mar 15, 16:22 CET
Investigating - We have detected an issue with Ledger services for blockchain Solana (SOL) Mainnet. This is being investigated by the team.
Mar 15, 16:12 CET
Mar 14, 2024
Resolved - This incident has been resolved.
Mar 14, 16:28 CET
Investigating - We have detected an issue with fetching the latest blockchain data from Cronos (CRO) Mainnet. This is being investigated by the team.
Mar 14, 11:51 CET
Resolved - This incident has been resolved.
Mar 14, 01:44 CET
Investigating - We have detected an issue with fetching the latest blockchain data from Tron (TRX) Mainnet. This is being investigated by the team.
Mar 14, 00:36 CET