DOGE Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 19, 2020 - 00:39 CET
Investigating
DOGE Explorer API Latency is very high.
Posted Nov 19, 2020 - 00:34 CET
This incident affected: Ledger Explorers (Doge (DOGE)).