"Explorer BCH" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jul 22, 2020 - 16:02 CEST
Investigating
Error code HTTP 503 - Service Unavailable
Posted Jul 22, 2020 - 15:23 CEST
This incident affected: Ledger Explorers (Bitcoin Cash (BCH)).