XTZ synchronisation issues
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 26, 2022 - 21:34 CEST
Update
We are continuing to investigate this issue.
Posted Sep 26, 2022 - 19:00 CEST
Investigating
We are currently investigating this issue.
Posted Sep 26, 2022 - 18:58 CEST
This incident affected: Ledger Explorers (Tezos (XTZ)).