SOL Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 03, 2022 - 09:49 CEST
Investigating
We have detected a problem with getting latest blockchain data from SOL Explorer. We are checking this incident.
Posted Aug 03, 2022 - 09:42 CEST
This incident affected: Ledger Explorers (Solana (SOL)).