XST explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jul 02, 2020 - 10:54 CEST
Investigating
XST explorer API test has failures detected. We are checking this incident.
Posted Jul 02, 2020 - 10:46 CEST