BTC Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 14:34 CEST
Investigating
We have detected a problem with getting latest blockchain data from BTC Explorer. We are checking this incident.
Posted Sep 20, 2022 - 14:06 CEST
This incident affected: Ledger Explorers (Bitcoin (BTC)).