"Explorer XRP" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 03:14 CEST
Investigating
Error code HTTP 503 - Service Unavailable
Posted Sep 09, 2020 - 02:38 CEST
This incident affected: Ledger Explorers (Ripple (XRP)).