"Explorer EGLD" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jan 09, 2023 - 14:17 CET
Investigating
Error code HTTP 503 - Service Unavailable
Posted Jan 09, 2023 - 08:02 CET
This incident affected: Ledger Explorers (Elrond (EGLD)).