BTC Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 20:03 CEST
Investigating
BTC Explorer API Latency is critical.
Posted Apr 02, 2021 - 19:44 CEST
This incident affected: Ledger Explorers (Bitcoin (BTC)).