DOGE Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 12:35 CEST
Investigating
We have detected a problem with getting latest blockchain data from DOGE Explorer. We are checking this incident.
Posted Sep 21, 2022 - 12:29 CEST
This incident affected: Ledger Explorers (Dogecoin (DOGE)).