CRO Node does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 11, 2022 - 14:51 CEST
Investigating
We have detected a problem with getting latest blockchain data from CRO Node. We are checking this incident.
Posted Aug 11, 2022 - 14:49 CEST
This incident affected: Ledger Explorers (Cronos (CRO)).