Explorer XSN is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 31, 2021 - 18:12 CEST
Investigating
Error code HTTP 500 - Internal Server Error
Posted May 31, 2021 - 18:04 CEST
This incident affected: Ledger Explorers (Stakenet (XSN)).