"Explorer PIVX" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jan 14, 2021 - 22:05 CET
Investigating
Error code HTTP 503 - Service Unavailable
Posted Jan 14, 2021 - 22:02 CET
This incident affected: Ledger Explorers (Pivx (PIVX)).