DOGE Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 25, 2020 - 16:41 CET
Investigating
DOGE Explorer API Latency is very high.
Posted Nov 25, 2020 - 16:38 CET
This incident affected: Ledger Explorers (Dogecoin (DOGE)).