ETC explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 12:26 CEST
Investigating
We have detected a problem with getting latest blockchain data from ETC explorer. We are checking this incident.
Posted Sep 21, 2022 - 12:18 CEST
This incident affected: Ledger Explorers (Ethereum Classic (ETC)).